VirtueMart

WooCommerce

Others

Docs

Support

Demo

Blog

About

Forum

We are currently unable to provide proper support!

For the last few months we have been very busy working on some huge, very time-consuming and time-sensitive projects, so our support was very limited and we were unable to provide proper support in our forums! We now have a huge backlog of requests from our customers, which we are trying to clear bit by bit. Unfortunately, this takes longer than we anticipated, so our response time is not yet up to par. We are trying our best to improve this situation as soon as possible.

Sorry for the inconvenience and thank you for your understanding!

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Unable to access plugin download URL. Please check

Unable to access plugin download URL. Please check 21 Jun 2017 21:31 #1

Hi
When I try to update credentials it gives me an error message:
Unable to access plugin download URL. Please check your credentials.
Thank you



DEBUG

Unable to access plugin download URL. Please check your credentials.
updateinfo: stdClass Object
(
[filename] => woocommerce-advanced-shipping-by-rules/woocommerce-advanced-shipping-by-rules.php
[slug] => woocommerce-advanced-shipping-by-rules
[response] => Array
(
[headers] => Requests_Utility_CaseInsensitiveDictionary Object
(
[data:protected] => Array
(
[date] => Wed, 21 Jun 2017 18:11:07 GMT
[server] => Apache/2.4.18 (Ubuntu)
[vary] => Accept-Encoding
[content-encoding] => gzip
[cache-control] => max-age=5
[expires] => Wed, 21 Jun 2017 18:11:12 GMT
[content-security-policy-report-only] => default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' www.gstatic.com www.google.com google.com maps.googleapis.com ; style-src 'self' 'unsafe-inline' fonts.googleapis.com www.google.com ajax.googleapis.com ; font-src 'self' fonts.gstatic.com; img-src 'self' www.open-tools.net open-tools.net www.wkoecg.at secure.gravatar.com csi.gstatic.com/csi extensions.virtuemart.net/ www.gravatar.com ; frame-src 'self' www.google.com/recaptcha/ www.facebook.com/plugins/like.php ; report-uri open-tools.net/csp-logger/logger.php opentools.report-uri.io/r/default/csp/reportOnly ;
[content-length] => 797
[content-type] => text/html; charset=UTF-8
)

)

[body] => {
"name": "WooCommerce Advanced Shipping by Rules",
"slug": "woocommerce-advanced-shipping-by-rules",
"homepage" : " www.open-tools.net/woocommerce/advanced-...for-woocommerce.html ",
"download_url": " www.open-tools.net/index.php?option=com_...rder_pass=p_vcaq6XuF ",
"version": "1.2.8",
"upgrade_notice" : "V1.2.8: Fix issues with UK variables before an address is entered",

"author": "Open Tools",
"author_homepage" : " www.open-tools.net/ ",
"sections": {
"description": "",
"installation" : "Simply click Update to install the new version. ",
"changelog" : "See the ChangeLog at open-tools.net.


V1.2.8: Fix issues with UK variables before an address is entered

V1.2.7: Add debug messages (disabled by default)

V1.2.6: Add messages to the rules (so errors, warnings, notices can be shown to the customer)

V1.2.5: Add variables userid, userroles, first_name, last_name, email, username

V1.2.4: Fix incompatibility with cash-on-delivery; fix extension filter

V1.2.3: Fix several PHP errors, update credentials input, etc.

V1.2.2: Fix warning about function signature mismatch

V1.2.1: Fix for warning with empty lines

V1.2: Support for multi-vendor plugins

V1.1.2: Fix for UK postcodes

V1.1.1: Fix for PHP 5.3, fix evaluate_for_XXX functions
"
}
}

[response] => Array
(
=> 200 [message] => OK ) [cookies] => Array ( ) [filename] => [http_response] => WP_HTTP_Requests_Response Object ( [response:protected] => Requests_Response Object ( [body] => { "name": "WooCommerce Advanced Shipping by Rules", "slug": "woocommerce-advanced-shipping-by-rules", "homepage" : " www.open-tools.net/woocommerce/advanced-...for-woocommerce.html ", "download_url": " www.open-tools.net/index.php?option=com_...rder_pass=p_vcaq6XuF ", "version": "1.2.8", "upgrade_notice" : "V1.2.8: Fix issues with UK variables before an address is entered", "author": "Open Tools", "author_homepage" : " www.open-tools.net/ ", "sections": { "description": "", "installation" : "Simply click Update to install the new version. ", "changelog" : "See the ChangeLog at open-tools.net. V1.2.8: Fix issues with UK variables before an address is entered V1.2.7: Add debug messages (disabled by default) V1.2.6: Add messages to the rules (so errors, warnings, notices can be shown to the customer) V1.2.5: Add variables userid, userroles, first_name, last_name, email, username V1.2.4: Fix incompatibility with cash-on-delivery; fix extension filter V1.2.3: Fix several PHP errors, update credentials input, etc. V1.2.2: Fix warning about function signature mismatch V1.2.1: Fix for warning with empty lines V1.2: Support for multi-vendor plugins V1.1.2: Fix for UK postcodes V1.1.1: Fix for PHP 5.3, fix evaluate_for_XXX functions " } } [raw] => HTTP/1.1 200 OK Date: Wed, 21 Jun 2017 18:11:07 GMT Server: Apache/2.4.18 (Ubuntu) Vary: Accept-Encoding Content-Encoding: gzip Cache-Control: max-age=5 Expires: Wed, 21 Jun 2017 18:11:12 GMT Content-Security-Policy-Report-Only: default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' www.gstatic.com www.google.com google.com maps.googleapis.com ; style-src 'self' 'unsafe-inline' fonts.googleapis.com www.google.com ajax.googleapis.com ; font-src 'self' fonts.gstatic.com; img-src 'self' www.open-tools.net open-tools.net www.wkoecg.at secure.gravatar.com csi.gstatic.com/csi extensions.virtuemart.net/ www.gravatar.com ; frame-src 'self' www.google.com/recaptcha/ www.facebook.com/plugins/like.php ; report-uri open-tools.net/csp-logger/logger.php opentools.report-uri.io/r/default/csp/reportOnly ; Content-Length: 797 Connection: close Content-Type: text/html; charset=UTF-8 { "name": "WooCommerce Advanced Shipping by Rules", "slug": "woocommerce-advanced-shipping-by-rules", "homepage" : " www.open-tools.net/woocommerce/advanced-...for-woocommerce.html ", "download_url": " www.open-tools.net/index.php?option=com_...rder_pass=p_vcaq6XuF ", "version": "1.2.8", "upgrade_notice" : "V1.2.8: Fix issues with UK variables before an address is entered", "author": "Open Tools", "author_homepage" : " www.open-tools.net/ ", "sections": { "description": "", "installation" : "Simply click Update to install the new version. ", "changelog" : "See the ChangeLog at open-tools.net. V1.2.8: Fix issues with UK variables before an address is entered V1.2.7: Add debug messages (disabled by default) V1.2.6: Add messages to the rules (so errors, warnings, notices can be shown to the customer) V1.2.5: Add variables userid, userroles, first_name, last_name, email, username V1.2.4: Fix incompatibility with cash-on-delivery; fix extension filter V1.2.3: Fix several PHP errors, update credentials input, etc. V1.2.2: Fix warning about function signature mismatch V1.2.1: Fix for warning with empty lines V1.2: Support for multi-vendor plugins V1.1.2: Fix for UK postcodes V1.1.1: Fix for PHP 5.3, fix evaluate_for_XXX functions " } } [headers] => Requests_Response_Headers Object ( [data:protected] => Array ( [date] => Array ( [0] => Wed, 21 Jun 2017 18:11:07 GMT ) [server] => Array ( [0] => Apache/2.4.18 (Ubuntu) ) [vary] => Array ( [0] => Accept-Encoding ) [content-encoding] => Array ( [0] => gzip ) [cache-control] => Array ( [0] => max-age=5 ) [expires] => Array ( [0] => Wed, 21 Jun 2017 18:11:12 GMT ) [content-security-policy-report-only] => Array ( [0] => default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' www.gstatic.com www.google.com google.com maps.googleapis.com ; style-src 'self' 'unsafe-inline' fonts.googleapis.com www.google.com ajax.googleapis.com ; font-src 'self' fonts.gstatic.com; img-src 'self' www.open-tools.net open-tools.net www.wkoecg.at secure.gravatar.com csi.gstatic.com/csi extensions.virtuemart.net/ www.gravatar.com ; frame-src 'self' www.google.com/recaptcha/ www.facebook.com/plugins/like.php ; report-uri open-tools.net/csp-logger/logger.php opentools.report-uri.io/r/default/csp/reportOnly ; ) [content-length] => Array ( [0] => 797 ) [content-type] => Array ( [0] => text/html; charset=UTF-8 ) ) ) [status_code] => 200 [protocol_version] => 1.1 [success] => 1 [redirects] => 0 [url] => http://www.open-tools.net/UpdateServer/index.php?package=WooCommerce&extension=AdvancedShippingByRules&installed_version=2.0&order_number=WC-17-1057&order_pass=p_vcaq6XuF [history] => Array ( ) [cookies] => Requests_Cookie_Jar Object ( [cookies:protected] => Array ( ) ) ) [filename:protected] => [data] => [headers] => [status] => ) ) ) => 200 [message] => OK ) [cookies] => Array ( ) [filename] => [http_response] => WP_HTTP_Requests_Response Object ( [response:protected] => Requests_Response Object ( [body] => { "name": "WooCommerce Advanced Shipping by Rules", "slug": "woocommerce-advanced-shipping-by-rules", "homepage" : "www.open-tools.net/woocommerce/advanced-...for-woocommerce.html", "download_url": "www.open-tools.net/index.php?option=com_...rder_pass=p_vcaq6XuF", "version": "1.2.8", "upgrade_notice" : "V1.2.8: Fix issues with UK variables before an address is entered", "author": "Open Tools", "author_homepage" : "www.open-tools.net/", "sections": { "description": "", "installation" : "Simply click Update to install the new version. ", "changelog" : "See the ChangeLog at open-tools.net. V1.2.8: Fix issues with UK variables before an address is entered V1.2.7: Add debug messages (disabled by default) V1.2.6: Add messages to the rules (so errors, warnings, notices can be shown to the customer) V1.2.5: Add variables userid, userroles, first_name, last_name, email, username V1.2.4: Fix incompatibility with cash-on-delivery; fix extension filter V1.2.3: Fix several PHP errors, update credentials input, etc. V1.2.2: Fix warning about function signature mismatch V1.2.1: Fix for warning with empty lines V1.2: Support for multi-vendor plugins V1.1.2: Fix for UK postcodes V1.1.1: Fix for PHP 5.3, fix evaluate_for_XXX functions " } } [raw] => HTTP/1.1 200 OK Date: Wed, 21 Jun 2017 18:11:07 GMT Server: Apache/2.4.18 (Ubuntu) Vary: Accept-Encoding Content-Encoding: gzip Cache-Control: max-age=5 Expires: Wed, 21 Jun 2017 18:11:12 GMT Content-Security-Policy-Report-Only: default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' www.gstatic.com www.google.com google.com maps.googleapis.com ; style-src 'self' 'unsafe-inline' fonts.googleapis.com www.google.com ajax.googleapis.com ; font-src 'self' fonts.gstatic.com; img-src 'self' www.open-tools.net open-tools.net www.wkoecg.at secure.gravatar.com csi.gstatic.com/csi extensions.virtuemart.net/ www.gravatar.com ; frame-src 'self' www.google.com/recaptcha/ www.facebook.com/plugins/like.php ; report-uri open-tools.net/csp-logger/logger.php opentools.report-uri.io/r/default/csp/reportOnly ; Content-Length: 797 Connection: close Content-Type: text/html; charset=UTF-8 { "name": "WooCommerce Advanced Shipping by Rules", "slug": "woocommerce-advanced-shipping-by-rules", "homepage" : "www.open-tools.net/woocommerce/advanced-...for-woocommerce.html", "download_url": "www.open-tools.net/index.php?option=com_...rder_pass=p_vcaq6XuF", "version": "1.2.8", "upgrade_notice" : "V1.2.8: Fix issues with UK variables before an address is entered", "author": "Open Tools", "author_homepage" : "www.open-tools.net/", "sections": { "description": "", "installation" : "Simply click Update to install the new version. ", "changelog" : "See the ChangeLog at open-tools.net. V1.2.8: Fix issues with UK variables before an address is entered V1.2.7: Add debug messages (disabled by default) V1.2.6: Add messages to the rules (so errors, warnings, notices can be shown to the customer) V1.2.5: Add variables userid, userroles, first_name, last_name, email, username V1.2.4: Fix incompatibility with cash-on-delivery; fix extension filter V1.2.3: Fix several PHP errors, update credentials input, etc. V1.2.2: Fix warning about function signature mismatch V1.2.1: Fix for warning with empty lines V1.2: Support for multi-vendor plugins V1.1.2: Fix for UK postcodes V1.1.1: Fix for PHP 5.3, fix evaluate_for_XXX functions " } } [headers] => Requests_Response_Headers Object ( [data:protected] => Array ( [date] => Array ( [0] => Wed, 21 Jun 2017 18:11:07 GMT ) [server] => Array ( [0] => Apache/2.4.18 (Ubuntu) ) [vary] => Array ( [0] => Accept-Encoding ) [content-encoding] => Array ( [0] => gzip ) [cache-control] => Array ( [0] => max-age=5 ) [expires] => Array ( [0] => Wed, 21 Jun 2017 18:11:12 GMT ) [content-security-policy-report-only] => Array ( [0] => default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' www.gstatic.com www.google.com google.com maps.googleapis.com ; style-src 'self' 'unsafe-inline' fonts.googleapis.com www.google.com ajax.googleapis.com ; font-src 'self' fonts.gstatic.com; img-src 'self' www.open-tools.net open-tools.net www.wkoecg.at secure.gravatar.com csi.gstatic.com/csi extensions.virtuemart.net/ www.gravatar.com ; frame-src 'self' www.google.com/recaptcha/ www.facebook.com/plugins/like.php ; report-uri open-tools.net/csp-logger/logger.php opentools.report-uri.io/r/default/csp/reportOnly ; ) [content-length] => Array ( [0] => 797 ) [content-type] => Array ( [0] => text/html; charset=UTF-8 ) ) ) [status_code] => 200 [protocol_version] => 1.1 [success] => 1 [redirects] => 0 [url] => http://www.open-tools.net/UpdateServer/index.php?package=WooCommerce&extension=AdvancedShippingByRules&installed_version=2.0&order_number=WC-17-1057&order_pass=p_vcaq6XuF [history] => Array ( ) [cookies] => Requests_Cookie_Jar Object ( [cookies:protected] => Array ( ) ) ) [filename:protected] => [data] => [headers] => [status] => ) ) )[code] => 200
[message] => OK
)

[cookies] => Array
(
)

[filename] =>
[http_response] => WP_HTTP_Requests_Response Object
(
[response:protected] => Requests_Response Object
(
[body] => {
"name": "WooCommerce Advanced Shipping by Rules",
"slug": "woocommerce-advanced-shipping-by-rules",
"homepage" : " www.open-tools.net/woocommerce/advanced-...for-woocommerce.html ",
"download_url": " www.open-tools.net/index.php?option=com_...rder_pass=p_vcaq6XuF ",
"version": "1.2.8",
"upgrade_notice" : "V1.2.8: Fix issues with UK variables before an address is entered",

"author": "Open Tools",
"author_homepage" : " www.open-tools.net/ ",
"sections": {
"description": "",
"installation" : "Simply click Update to install the new version. ",
"changelog" : "See the ChangeLog at open-tools.net.


V1.2.8: Fix issues with UK variables before an address is entered

V1.2.7: Add debug messages (disabled by default)

V1.2.6: Add messages to the rules (so errors, warnings, notices can be shown to the customer)

V1.2.5: Add variables userid, userroles, first_name, last_name, email, username

V1.2.4: Fix incompatibility with cash-on-delivery; fix extension filter

V1.2.3: Fix several PHP errors, update credentials input, etc.

V1.2.2: Fix warning about function signature mismatch

V1.2.1: Fix for warning with empty lines

V1.2: Support for multi-vendor plugins

V1.1.2: Fix for UK postcodes

V1.1.1: Fix for PHP 5.3, fix evaluate_for_XXX functions
"
}
}

[raw] => HTTP/1.1 200 OK
Date: Wed, 21 Jun 2017 18:11:07 GMT
Server: Apache/2.4.18 (Ubuntu)
Vary: Accept-Encoding
Content-Encoding: gzip
Cache-Control: max-age=5
Expires: Wed, 21 Jun 2017 18:11:12 GMT
Content-Security-Policy-Report-Only: default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' www.gstatic.com www.google.com google.com maps.googleapis.com ; style-src 'self' 'unsafe-inline' fonts.googleapis.com www.google.com ajax.googleapis.com ; font-src 'self' fonts.gstatic.com; img-src 'self' www.open-tools.net open-tools.net www.wkoecg.at secure.gravatar.com csi.gstatic.com/csi extensions.virtuemart.net/ www.gravatar.com ; frame-src 'self' www.google.com/recaptcha/ www.facebook.com/plugins/like.php ; report-uri open-tools.net/csp-logger/logger.php opentools.report-uri.io/r/default/csp/reportOnly ;
Content-Length: 797
Connection: close
Content-Type: text/html; charset=UTF-8

{
"name": "WooCommerce Advanced Shipping by Rules",
"slug": "woocommerce-advanced-shipping-by-rules",
"homepage" : " www.open-tools.net/woocommerce/advanced-...for-woocommerce.html ",
"download_url": " www.open-tools.net/index.php?option=com_...rder_pass=p_vcaq6XuF ",
"version": "1.2.8",
"upgrade_notice" : "V1.2.8: Fix issues with UK variables before an address is entered",

"author": "Open Tools",
"author_homepage" : " www.open-tools.net/ ",
"sections": {
"description": "",
"installation" : "Simply click Update to install the new version. ",
"changelog" : "See the ChangeLog at open-tools.net.


V1.2.8: Fix issues with UK variables before an address is entered

V1.2.7: Add debug messages (disabled by default)

V1.2.6: Add messages to the rules (so errors, warnings, notices can be shown to the customer)

V1.2.5: Add variables userid, userroles, first_name, last_name, email, username

V1.2.4: Fix incompatibility with cash-on-delivery; fix extension filter

V1.2.3: Fix several PHP errors, update credentials input, etc.

V1.2.2: Fix warning about function signature mismatch

V1.2.1: Fix for warning with empty lines

V1.2: Support for multi-vendor plugins

V1.1.2: Fix for UK postcodes

V1.1.1: Fix for PHP 5.3, fix evaluate_for_XXX functions
"
}
}

[headers] => Requests_Response_Headers Object
(
[data:protected] => Array
(
[date] => Array
(
[0] => Wed, 21 Jun 2017 18:11:07 GMT
)

[server] => Array
(
[0] => Apache/2.4.18 (Ubuntu)
)

[vary] => Array
(
[0] => Accept-Encoding
)

[content-encoding] => Array
(
[0] => gzip
)

[cache-control] => Array
(
[0] => max-age=5
)

[expires] => Array
(
[0] => Wed, 21 Jun 2017 18:11:12 GMT
)

[content-security-policy-report-only] => Array
(
[0] => default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' www.gstatic.com www.google.com google.com maps.googleapis.com ; style-src 'self' 'unsafe-inline' fonts.googleapis.com www.google.com ajax.googleapis.com ; font-src 'self' fonts.gstatic.com; img-src 'self' www.open-tools.net open-tools.net www.wkoecg.at secure.gravatar.com csi.gstatic.com/csi extensions.virtuemart.net/ www.gravatar.com ; frame-src 'self' www.google.com/recaptcha/ www.facebook.com/plugins/like.php ; report-uri open-tools.net/csp-logger/logger.php opentools.report-uri.io/r/default/csp/reportOnly ;
)

[content-length] => Array
(
[0] => 797
)

[content-type] => Array
(
[0] => text/html; charset=UTF-8
)

)

)

[status_code] => 200
[protocol_version] => 1.1
[success] => 1
[redirects] => 0
[url] => http://www.open-tools.net/UpdateServer/index.php?package=WooCommerce&extension=AdvancedShippingByRules&installed_version=2.0&order_number=WC-17-1057&order_pass=p_vcaq6XuF
[history] => Array
(
)

[cookies] => Requests_Cookie_Jar Object
(
[cookies:protected] => Array
(
)

)

)

[filename:protected] =>
[data] =>
[headers] =>
[status] =>
)

)

)

Please Log in or Create an account to join the conversation.

Unable to access plugin download URL. Please check 24 Jun 2017 22:32 #2

Dear Cinthi,
Thank you very much for the debug log!
It indicates that your server is properly able to load the update information from our servers, but it fails parsing the update information (in JSON format) into its internal data structure. That led me to the actual cause of the problem: In our update information we inadvertently used a tab character once instead of spaces! The JSON specification forbids tabs inside JSON strings (tabs can be used for indentation, though!), so formally speaking, our update information was invalid JSON.

While most installations will still be able to properly decode the JSON-string containing the update information, your server apparently was not able (no idea whether it depends on the PHP version, the operating system or some installed packages).

We have now fixed the update information to fully conform to the JSON specification. Can you please re-try?

Thank you,
Reinhold

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

VM - Shopping cart

 x 

Cart empty

Login Formular