VirtueMart

WooCommerce

Others

Docs

Support

Blog

About

Forum

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: [SOLVED] PHP 7 Compatibility

PHP 7 Compatibility 21 Nov 2017 22:55 #1

Hi

I want to upgrade to PHP 7 and tested my plugins with this PHP linter:
wordpress.org/plugins/php-compatibility-checker/

There seems to be an issue with WooCommerce Advanced Shipping By Rules (Version 2.0.2).
FILE: /wp-content/plugins/woocommerce-advanced-shipping-by-rules/plugin-update-checker/vendor/Parsedown.php
FOUND 1 ERROR AFFECTING 1 LINE
 1412 | ERROR | Indirect access to variables, properties and methods will be evaluated strictly in left-to-right order since PHP 7.0. Use curly braces to remove ambiguity.

Is the plugin compatible with PHP 7, does anyone know?

Thanks!

Best, Philipp

Please Log in or Create an account to join the conversation.

PHP 7 Compatibility 02 Dec 2017 17:36 #2

Dear Philipp,
Sorry for the late reply and thank you for spotting this PHP7 incompatibility. Our plugin was always supposed to be compatibly with PHP 7, and we didn't ourselves experience any issues.
The incompatibilty was actually in a third-party library we use, and the code that triggers the warning/error was only to be used in legacy situations. The fix is quite trivial ( github.com/YahnisElsts/plugin-update-che...a4b1a5c5658518f44c06 ).

We fixed the pbolem and released version 2.0.3, which should show up as an update in your plugin list shortly.

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

PHP 7 Compatibility 02 Dec 2017 18:36 #3

Thank you so much Reinhold!

Have a nice weekend.

Best, Philipp

Please Log in or Create an account to join the conversation.

[SOLVED] PHP 7 Compatibility 02 Dec 2017 18:36 #4

Problem solved.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

VM - Shopping cart

 x 

Cart empty

Login Formular