Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Problem with comma and min/max amount

Problem with comma and min/max amount 13 Oct 2015 00:07 #1

  • Picannick
  • Picannick's Avatar Topic Author
  • Offline
  • Posts: 1
First thank you for this easy-to-use-and does-what-it-should-do-plugin!

There is only one question left: How could i disallow cents? Or why this plugin doesn't use the vm currency-settings?
I set min to 40 and max to 2000 €
If you are typing 50,50 € (this is the correct one for our country for example we are typing 5.800,99 €) the errormessage is:

"The value 50 you entered is larger than the largest allowed value, using the maximum value 2000 instead."

Is there a possibility fix it?
Thanks in advanced!

Please Log in or Create an account to join the conversation.

Problem with comma and min/max amount 15 Oct 2015 01:59 #2

Dear Picannick,
There is currently no way to disallow cents, sorry.
Also, taking the amount from the input box and sending it to the virtuemart server is done by Javascript in the customer's web browser, so the usual PHP settings (e.g. virtuemart settings) are not automatically obeyed.

Unfortunately, I am terribly short on time in the foreseeable future, so I'm afraid I won't find the time to fix any of these issues.

Notice, however, that the plugin is released under an open source license and that the source code is publicly available for improvements:
You are cordially invited to work on the PHP and JS code yourself and submit a patch (or pull request on github). I'll gladly consider any patches I get, I just don't have the time to do the development myself.

Best regards,

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

VM - Shopping cart


Cart empty

Login Formular