Advanced Ordernumbers for VirtueMart

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!



The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1


Global Counter does not work 17 May 2015 22:54 #1

  • kcalvis
  • kcalvis's Avatar Topic Author
I am using the latest version. I agree that I should use a global counter for customer number.
However, I find that the global counter does not work when I set up a custom customer number.
It seems that the global counter is not working for others too in my case.

Let's study my case first on customer number.
I set up with the following format "HKAN-[randomULetter1][randomHex1]-F#" with setting 6-digit and using global counter.

First time: When I add a new user into the VM system, the plugin works well and gives that user a new customer number like: HKAN-Ga-F000001
Second: When I add another new user into the VM system, the plugin gives the new user a new customer number like: HKAN-Eb-F000001
After: (the same as the second: HKAN-S2-F1, HKAN-W9-F1, ...etc)

Oh, the counter never increases. When I look into the config page of the plugin, I find the some formatted counters are recorded. They are:
HKAN-Ga-F# (counter: 1)
HKAN-Eb-F# (counter: 1)
HKAN-S2-F# (counter: 1)

The plugin doesn't set up any global counter for me but records down the random prefix as a part of the format! Since the prefix of the next customer number is not the same as the those recorded cases. The counter never increases and keeps 1.

I have tried this format of "HKAN-[randomULetter1][randomHex1]-F#" with same setting in order number and invoice number but they fails too.

Also, I have tried to add a global counter into the database both by config interface and by phpMyAdmin directly first but fail too.
The global counter never be loaded, used, and increased.

Added by phpMyAdmin to database:
Case 1: If specify only "count" but not "number_type" and "number_format", this counter will not be showed as global counter in all. No use.
Case 2: If specify both "number_type" and "count" but not "number_format", this counter will be showed as global counter in specified like customer_number. No use too indeed even it shows in config page. (Also, when I edit this, another record appears in DB like case 1. And it will not be showed...)
Is global counter not really a global value for everything? It seems every item has its own global counter...anyways, don't work...

What is the problem? Could it be solved?

Global Counter does not work 23 May 2015 21:38 #2

Thank you for the bug report. You are indeed correct that some last-minute changes before the 3.0 release of the plugin broke the global counters...
Please update to version 3.1 of the plugin, which I just uploaded to our Homepage.

Sorry for the inconvenience,

Global Counter does not work 24 May 2015 18:11 #3

  • kcalvis
  • kcalvis's Avatar Topic Author
Thanks for your prompt response!

[SOLVED] Global Counter does not work 02 Jun 2015 00:51 #4

Problem solved.
  • Page:
  • 1