Advanced Ordernumbers for VirtueMart

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!



The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1


Invoice number doesn`t work 09 Nov 2015 16:21 #1

  • meineseite
  • meineseite's Avatar Topic Author

I use Joomla 3.4.5, Virtuemart 3.0.10 and the Advanced Ordernumber 3.2. I enabled and it works for the order number.
But not for the invoice numbers. Change invoice number = ON and I use the default formt.

But nothing changed. I always have the random number from VirtueMart :-(. Where can be the problem?


Invoice number doesn`t work 13 Nov 2015 11:50 #2

  • plomp`
  • plomp`'s Avatar
i have exact the same problem!
It worked fine before, but suddenly it stopt creating invoicenumbers.

please help us!

Invoice number doesn`t work 13 Nov 2015 19:43 #3

  • dgallego
  • dgallego's Avatar
Same problem here, using j3.4.5 vm3.0.10 and vm3.0.12... please patch / fix asap

Invoice number doesn`t work 14 Nov 2015 16:22 #4

Dear All,
Do you manually create the invoice in the VirtueMart backend, or automatically with the confirmation mail. We are aware of a regression in the latest virtuemart version, where the manual creation (clicking on the invoice link in the order list in the VM backend) does not properly work. We are currently trying to track down the exact location of the bug, but this is a VirtueMart problem, so unfortunately it cannot be fixed in the plugin itself.

We'll try to keep you updated on this issue.

Invoice number doesn`t work 15 Nov 2015 00:46 #5

Please try Version 3.3, which we have just released. That version adds a workaround for the changed way VM creates the invoice (in particular, VM changed the checks when to create an invoice in a way incompatible with past versions).

Best regards,

Invoice number doesn`t work 15 Nov 2015 10:12 #6

  • plomp`
  • plomp`'s Avatar
ok great, where can i download the update?

I bought the plugin trough www.virtuemart.net (see attachment)
[Edit: Attachment removed for privacy / security reasons]

Can you send it by e-mail to me?

Invoice number doesn`t work 15 Nov 2015 20:36 #7

  • dgallego
  • dgallego's Avatar
Hi, it doesn't work,

also, the update deleted part of the existing config (restarted the counter), at least the automated process is still working... but not a fix for the manual creation issue, at all.

Invoice number doesn`t work 15 Nov 2015 23:00 #8

Dear DGallego,
Thanks for hinting at the configuration issue. There was indeed a typo in the SQL update code, which accidentally convert all invoice counters to order number counters. I'll release a fix (version 3.4) in a few minutes.

I have cross-checked the version on our test systems, and while I was able to reproduce the issue with earlier versions of the plugin, the latest version 3.3 (and 3.4) of the plugin correctly generated invoice numbers when the invoice was created manually in the backend.

Please note that the plugin will not assign invoice numbers to orders for which an invoice has already been created. Only new orders will get an invoice number assigned by the plugin.

Could you please cross-check that invoice numbers for new orders are created?

Best regards,

Invoice number doesn`t work 16 Nov 2015 14:39 #9

  • meineseite
  • meineseite's Avatar Topic Author
Today I tried version 3.4.
Still not working :-(

And since I installed the last update for VirtueMart the invoice is generated in automatic.
How can I disable the automatic invoice creation?

Invoice number doesn`t work 16 Nov 2015 15:29 #10

  • plomp`
  • plomp`'s Avatar
I installed 3.4 and it works perfect!
Thanks :-)

I manually create invoices but i noticed that i must do it in the right order.
When order is send, i choose status "send" and after that i click the "invoice+" icon.

If i do it otherwise it will not work. Then VM creates an other invoicenummber.
Maybe that's the solution for some people?

Invoice number doesn`t work 13 Dec 2015 10:40 #11

  • pcmilhouse
  • pcmilhouse's Avatar
I've the same problem with plugin version 3.4.5 & VM 3.0.10.
It creates VM random invoice number even if plugin is enabled.

Anyone for a solution?


Invoice number doesn`t work 13 Dec 2015 17:11 #12

Dear PcMilHouse,
I suppose the random invoice numbers were only assigned when you manually created the invoice in the VM backend for old orders that were created before VM 3.0.10.

For these, we have now also identified the issue (again, due to VM's changed way to create invoices manually, the database has changed old orders, which needed some further adjustments in our plugin for old orders).
Please try version 3.6 of the ordernumber plugin.

Best regards,

Invoice number doesn`t work 18 Dec 2015 09:59 #13

  • pcmilhouse
  • pcmilhouse's Avatar
I've installed ver. 3.6 but still have the problem both in manuale invoice creation and automatic creation.
What could be the problem?
Could you check and let me know?


Invoice number doesn`t work 30 Dec 2015 15:53 #14

Dear Pcmilhouse,
Unfortunately, I am no longer able to reproduce the issue. Do you have any other extensions installed that might interfere with the order/invoice number creations (like Rupostel OnePage Checkout, VMInvoice, etc.)?

Do you have a test/development setup somewhere, where I could test and reproduce the issue (or inspect whether your settings are the issue)?

Best regards,
  • Page:
  • 1