VirtueMart

WooCommerce

Others

Docs

Support

Blog

About

Shipping by Rules for VirtueMart

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Cart not working with two shipping by rule options

Cart not working with two shipping by rule options 16 Aug 2017 10:19 #1

Hello,
the shipping by rules works fine up until I add a second shipping by rules option, once the second option is published, when I try showing the shopping cart page, it just gives me a blank white page (no error).

Here is how the rules are set:
The shipping is different for packages longer and shorter than 600mm, and it varies with the total package weight.
So, for the Economy shipping I have set the following (for 8 country zones):

Name=Europe - up to 50gr; MaxLength<=600; weight<50; Shipping=4
Name=Europe - up to 100gr; MaxLength<=600; weight<100; Shipping=4.5
Name=Europe - up to 250gr; MaxLength<=600; weight<250; Shipping=7.5

Name=Europe - up to 1000gr; MaxLength>600; weight<1000; Shipping=29
Name=Europe - up to 2000gr; MaxLength>600; weight<2000; Shipping=33
Name=Europe - up to 5000gr; MaxLength>600; weight<5000; Shipping=47


And I have the same for priority shipping, same length, same weight but different shipping price, and when I publish that premium shipping, it shows blank page. But, when I unpublish the Economy shipping and publish the Premium one, it is working fine, so the problem only occurs when two options are published at the same time.

Could anyone help me with this as I have no idea what could cause it?

Thank you in advance,
Matija

Please Log in or Create an account to join the conversation.

Cart not working with two shipping by rule options 24 Aug 2017 19:45 #2

Dear Matija,
A blank white page typically indicates a fatal PHP error. Could you please enable PHP error reporting ("development" mode) as described in this forum post: open-tools.net/forum/shipping-by-rules-p...tion-to-include.html

With that setting, the php error message should be shown on screen instead of the blank page...

Could you please copy the exact error message(s) and also all version numbers (as describe in the above mentioned forum post).

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

VM - Shopping cart

 x 

Cart empty

Login Formular