VirtueMart

WooCommerce

Others

Docs

Support

Demo

Blog

About

Forum

We are currently unable to provide proper support!

We are very sorry to announce that we are currently very busy working on some huge, very time-consuming and time-sensitive projects, so currently we are unable to provide proper support in our forums! We hope that after the conclusion by the end of July we will be able to properly answer all open support requests.

Sorry for the inconvenience and thank you for your understanding!

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC: Fatal Error

Fatal Error 14 Nov 2017 11:49 #1

  • syzygaladmin
  • syzygaladmin's Avatar Topic Author
  • Offline
  • Posts: 2
Hello,

I have just tried to install the advanced shipping rules plugin into wordpress and have received this error when trying to activate it

Fatal error: Cannot declare class RulesShippingFrameworkWooCommerce, because the name is already in use in /wpcom-136350349/wp-content/plugins/woocommerce-advanced-shipping-by-rules/includes/rules_shipping_framework_woocommerce.php on line 501

I have previously tried your free plugin and this activated OK without any error messages.
I am running WordPress 4.8.3 and have not had any issues with any other plugins at all.

Please advise.

Please Log in or Create an account to join the conversation.

Fatal Error 16 Nov 2017 08:48 #2

  • syzygaladmin
  • syzygaladmin's Avatar Topic Author
  • Offline
  • Posts: 2
Does anybody know how we can contact the plugin author for support?

Please Log in or Create an account to join the conversation.

Fatal Error 19 Nov 2017 12:06 #3

Dear Syzygaladmin,
Sorry to hear about your issues. Unfortunately, we have not yet been able to reproduce the issue on any of our test systems. You are, however, the second user to report this error message, so there is certainly a problem somewhere, we just haven't figured out where.

See also: open-tools.net/forum/ordernumber-plugin/5470-error.html#8291

Do you still have both the free and the paid versions of the plugin installed and enabled? Both rely on the same framework class (which the error message is about) and load the corresponding file. Normally, the free version should disable itself when it detects the advanced version being installed.

Apparently, in your case this automatic disablement seems to have failed. Can you try disabling the free version manually in the WordPress plugin area and check if this solved the issue?



If this does not solve the issue, then my next attempt would be to comment out the code to load the legacy support (support for old shipping rules from before the switch to shipping zones). I tried describing this at open-tools.net/forum/shipping-by-rules-f...o-activate.html#8290 for a different issue.

If you are uneasy about changingthese files, of have no idea how you could do this, we can figure out another way to track down the issue. As I said, we have not yet been able to reproduce the issue locally, so we'd then have to figure out the differences between your installation and our test systems. As a first start, could you please tell us your versions of:
- WordPress
- WooCommerce
- PHP

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

VM - Shopping cart

 x 

Cart empty

Login Formular