Ordernumbers for WooCommerce

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!



The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1


How to reset invoice numbers back to 0 06 Jun 2016 18:14 #1

  • nukerman
  • nukerman's Avatar Topic Author

I did a few test orders on my site using the invoice number format [#####:1/1] but would like everything reset back!

I went ahead and manually changed the invoice number of the first real order to 00001 in phpmyadmin (wp_options). However, I did a test order and the next invoice was generated as 00006. I also tried to add a new counter in the "All invoice number counters" section using the name #####, but after clicking save changes it dissappeared. I tried to add it in again but it gave me an error message about not being authorized to do so (see screenshot).

So, why can't I manually add new counters ( they show up initially but after clicking save they dissappear)? And, how to I reset this so that my next order invoice numbers shows up as 00002?


How to reset invoice numbers back to 0 09 Jun 2016 22:32 #2

Dear Nukerman,
Which version of the plugin do you have installed? We fixed some issues with modifications not working / disappearing a while ago.
Could you please upgrade to the latest version and check again?

Regarding the authorization error messages: There might be several causes of this issue.
  • Which version of PHP do you have installed? (Sometimes older versions like 5.3 cause problems server-side)
  • Do you get any php warnings/error messages in your webserver's log files?
  • Do you get any JavaScript warnings/errors in your webbrowser's console? (E.g. in Chrome that would be F12 -> "Console" tab)
  • What is the AJAX response of the server? To get this, again press F12 in your browser to have the developer console appear. In Chrome, you would then go to the "Network" tab of the dev console. Now, try to add a new counter => In the "Network" tab there should appear a call to admin-ajax.php. Click on it to see the contents of your server's response on the right side of the dev console. If everything worked out, the response should be something like
  • Do you have multisite mode enabled on your WP installation?

Best regards,
  • Page:
  • 1