Name The Price for VirtueMart

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!



The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1


Amounts > 999 11 Jun 2016 22:11 #1

  • Thomas
  • Thomas's Avatar Topic Author

I'm using the name the price on a shop for a non-profit organisation. There's a strange behavior in case of amounts >999. It's displayed with a chinese sign instead of the correct amount. See the Picture for an example.

Any idea what's wrong? I'm using Joomla 3.5.1 and Virtuemart 3.0.14.

Thanks for your help.

Cheers, Thomas

Amounts > 999 15 Jun 2016 01:11 #2

Dear Thomas,
I have tried to reproduce the problem on our machines, but have not been able so far (using the default template and VM 3.x on J 3.5.x with PHP 5.5.x, Apache, Ubuntu 15.10).

To me there are only two possible causes:
1. Your template somehow messes up the display (the new price is inserted via AJAX calls)
2. Your Server somehow returns the response to the AJAX call in ASCII, while your browser assumes UTF-8 and thus wrongly converts the displayed amount.

In any case, our plugin does not do anything at that point, but rather uses VirtueMart's default custom field price logic. So I would assume that the same issue arrises if you use e.g. a custom field using the text input plugin shipped with VM (set the cost per letter to a high value).

Best regards,

Amounts > 999 15 Jun 2016 10:12 #3

  • Thomas
  • Thomas's Avatar Topic Author
Dear Reinhold

Thanks for your quick help. I made some more investigations and found finally the problem. It was a wrong sign in the 1000 delimiter configuration. After replacing the sign with the correct ' everything worked fine.

Kind regards


[SOLVED] Amounts > 999 15 Jun 2016 10:12 #4

  • Thomas
  • Thomas's Avatar Topic Author
Problem solved.
  • Page:
  • 1