Shipping by Rules for VirtueMart

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!



The forum is in read only mode.
Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1


Something Changed and get this error 29 May 2014 17:08 #1

  • CreativeKev
  • CreativeKev's Avatar Topic Author
Hi, I had VirtueMart working on a site rockhoundsupplies.com
and then my server changed IP addresses for the domain and when we finally got that figured out, I was unable to access the site, once we got that figured out, which required me to restore from an earlier date, VirtueMart is starting to give me issues.

When I go to the VM component, I get the following message.
vmdebug $siteLang: en-GB self::$_jpConfig->lang en_gb
vmdebug vmTime: loadConfig db no: 0.00408601760864258
vmdebug Start used Ram 9.75M
vmdebug vmTime: VirtueMartControllerVirtuemart Finished task virtuemart: 0.035207986831665
vmdebug End used Ram 12.25M
vmdebug Peak memory peak 12.25M

I am using Joomla! 2.5.19
I was using Virtuemart 2.0.24

I tried to update the VirtueMart and first got an error, jinstaller Cannot Find XML,
Then I tried updating VirtueMart right from the component, and it seemed to update. Well kinda. If I go the the VM AIO it says I'm using 2.0.24, but when I'm in the VirtueMart Component Configuration it says VirtueMart 2.6.2

Any help would be appreciated as this was a working Component with a paid-for shipping module, and now it is not. :)

Something Changed and get this error 08 Jun 2014 17:50 #2

These messages are debug messages, so apparently your VM configuration has debugging messages turned on (VM -> Configuration -> Configuration -> "Shop" Tab -> Advanced Settings -> Enable debugging messages).

The AM AIO and the VirtueMart component itself are two different packages, so you'll have to update both. In particular, you'll always have to remember to update the VM AIO package, whenever you update the VM core.

Anyway, I don't see where my plugin causes any problems. Can you be a bit more specific what does not work with my shipping plugin?

Best regards,
  • Page:
  • 1