VirtueMart

WooCommerce

Others

Docs

Support

Blog

About

Shipping by Rules for VirtueMart

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

blank page after update 02 Jun 2016 07:11 #1

Hello I updated for the last version (plg_opentools_vm_rules_shipping_advanced_v6.1.5), and after install all the shipment methods gives blank page. I checked the error reports, and say the following:


Strict Standards: Declaration of plgVmShipmentRules_Shipping_Base::setCartPrices() should be compatible with vmPSPlugin::setCartPrices(VirtueMartCart $cart, &$cart_prices, $method, $progressive = true) in /home/prof/public_html/km/plugins/vmshipment/rules_shipping/rules_shipping_base.php on line 0

Notice: Undefined property: plgVmShipmentRules_Shipping_Advanced::$helper in /home/prof/public_html/km/plugins/vmshipment/rules_shipping_advanced/rules_shipping_advanced.php on line 36

Fatal error: Call to a member function registerCallback() on a non-object in /home/prof/public_html/km/plugins/vmshipment/rules_shipping_advanced/rules_shipping_advanced.php on line 36

Could you help me to solve this?

Thanks,
Regards,
Peter

Please Log in or Create an account to join the conversation.

blank page after update 07 Jun 2016 21:23 #2

Dear Peter,
Do you have an old version of the basic plugin installed? The two versions of the plugin share some code, so it might be that the old basic version is loaded before the newer advanced version.
As we added a lot of code (in particular the $helper object that the error message claims is missing) in the latest versions of the plugin, using an older free version of the plugin at the same time is problematic. Please upgrade the free plugin, too.

For now, this is the only situation that would explain the error message. If that is not our situation, please let me know so that we can investigate further...

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

VM - Shopping cart

 x 

Cart empty

Login Formular