VirtueMart

WooCommerce

Others

Docs

Support

Blog

About

Shipping by Rules for VirtueMart

IMPORTANT ANNOUNCEMENT: Plugin development ceased, all plugins made available freely (GPL)

With great sadness we have to announce that we are ceasing development of all our VirtueMart, WooCommerce and Joomla plugins. Effective immediately, all our plugins -- even those that were paid downloads -- are made available for free from our homepage (GPL license still applies), but we cannot and will not provide any support anymore.

It has been a great pleasure to be part of the thriving development communities of VirtueMart as well as WooCommerce. However, during the last year it became painstakingly clear that in addition to a full-time job, a young family and several other time-consuming hobbies at professional level (like being a professional singer) the plugin development and the support that it requires is not sustainable and is taking its toll. It has been an honor, but it is now time to say good bye!

Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1

TOPIC:

Zip not working at all 05 Dec 2016 16:04 #1

Hello there,

Virtuemart: 3.0.118
Joomla 3.6.4
PHP: 5.4.45

I tried the following:
10000<=ZIP<=19999 OR 53430<=ZIP<=57600; Amount>50; Shipping=0
10000<=ZIP<=19999 OR 53430<=ZIP<=57600; Weight > Volume AND Weight <= 3; Shipping=3.15
10000<=ZIP<=19999 OR 53430<=ZIP<=57600; Weight < Volume AND Volume <= 3; Shipping=3.15
10000<=ZIP<=19999 OR 53430<=ZIP<=57600; Weight == Volume AND Volume <= 3; Shipping=3.15
10000<=ZIP<=19999 OR 53430<=ZIP<=57600; Weight > Volume AND Weight > 3; Shipping=1.05*Weight
10000<=ZIP<=19999 OR 53430<=ZIP<=57600; Weight < Volume AND Volume > 3; Shipping=1.05*Volume
10000<=ZIP<=19999 OR 53430<=ZIP<=57600; Weight == Volume AND Volume > 3; Shipping=1.05*Volume
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight > Volume AND Weight <= 3; Amount > 99; Shipping=0
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight < Volume AND Volume <= 3; Amount > 99; Shipping=0
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight == Volume AND Volume <= 3; Amount > 99; Shipping=0
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight > Volume AND Weight <= 3; Amount <= 99; Shipping=3.15
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight < Volume AND Volume <= 3; Amount <= 99; Shipping=3.15
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight == Volume AND Volume <= 3; Amount <= 99; Shipping=3.15
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight > Volume AND Weight > 3; Amount > 299; Shipping=0
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight < Volume AND Volume > 3; Amount > 299; Shipping=0
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight == Volume AND Volume > 3; Amount > 299; Shipping=0
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight > Volume AND Weight > 3; Amount <= 299; Shipping=2.05*Weight
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight < Volume AND Volume > 3; Amount <= 299; Shipping=2.05*Volume
20000<=ZIP<=54429 OR 57601<=ZIP<=99999; Weight == Volume AND Volume > 3; Amount <= 299; Shipping=2.05*Volume

and it appears that whatever zip code i enter i get the amount 4.2 with one product of 4 kilos inside cart. And volume of this product is smaller than weight of the product. Any ideas?If i place a zip code for example 65302, then i should get as shipping 2.05*Weight but still i get 4.2

Thank you in advance

Please Log in or Create an account to join the conversation.

Zip not working at all 05 Dec 2016 20:47 #2

I just tried simple rules like:
10000<=ZIP<=19999;Shipping=1
20000<=ZIP<=30000;Shipping=2

Whatever zip i place i get Shipping=1

Also, i entered a debug code like the one from a forum post and it shows me correct weight, correct volue but wrong zip code.

I don't know if this helps, but i have deactivaed buys for guests, so you have to log in to buy. So, when you log in and go to cart, cart has already the zip code you entered at registration and according to this zip code, the calculation is made. If in cart page, i choose the delivery address to be different than the billing address and enter zip code there, then debug message brings the correct zip code, but if not, the debug shows always the zip code that i have as a customer and if i choose different zip code, it does not been taken into consideration.

Please Log in or Create an account to join the conversation.

Zip not working at all 07 Dec 2016 17:56 #3

Do we have an estimation of a help/support for this issue? I would be grateful if i had solution for this as soon as possible, because i bought plugin on Sunday and till today i cannot have the job done for my client. Please take a look and help to resolve this!

Thank you in advance!

Please Log in or Create an account to join the conversation.

Zip not working at all 08 Dec 2016 01:18 #4

Dear PM4698,
Sorry to hear you are running into issues with the ZIP code.
Thank you for the additional (crucial!) information that you are speaking about logged-in users where one either enters an explicit shipping address or modified the stored user address. Unfortunately, I still cannot reproduce the issue.

In my tests, when I enter an explicit shipping address, the ZIP code from the shipping address is correctly used, and if I do not enter a shipping address, but modify the ZIP code of the stored address of the customer, then the modified ZIP code is used.

Do you have any one-page checkout system installed?
It might be that some one-page checkout plugins do not properly update the address before recalculating the shipping costs. But that would be just a guess, because I'm not able to reproduce the issue with a simple installation (just core VirtueMart and our plugins, no third-party extensions that might interfere).

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

Zip not working at all 08 Dec 2016 06:10 #5

Dear Reinhold,

Indeed i use onepage checkout plugin, but here is the deal:

I tried this in another website and with the same one page checkout (and different rules at your plugin) when someone enters zip code for first time your plugin works and if he changes later zip code then again it works! So, generally this one page plugin does not have the real issue. But if the user has bought already and his data is saved then changing zip code does not work. But, it works with other shipping methods. I use default VM shipping methods with different zip codes, weights, free shipping, countries etc and when i change zip code at one page checkout, it refreshes normally the sipping methods

Please Log in or Create an account to join the conversation.

Zip not working at all 08 Dec 2016 08:02 #6

Also if you want me, i can send you this one page checkout to see and debug

Please Log in or Create an account to join the conversation.

Zip not working at all 08 Dec 2016 11:07 #7

Dear PM4698,
Thanks for the offer, it would indeed be very helpful to have the onepage checkout plugin you are using (there are lots of different OPC plugins available!).

So to summarize, with the following steps you can reproduce the issue at your site:
1) Install the OPC plugin and enable it
2) As a new customer, try to order something. During the checkout, all customers are required to create an account.
3) For that initial order, use a ZIP code of, say, 1234
4) As the user just created, try to make a second order.
5) For that second order, you try to change the ZIP code of the address to 9876. (NOT a separate shipping address, but really a modified billing address).
6) The checkout page will correctly show the changed ZIP 9876, but the shipping plugin still uses the old 1234 address?

Are these the steps to reproduce the issue?

Thanks,
Reinhold

Please Log in or Create an account to join the conversation.

Zip not working at all 08 Dec 2016 13:03 #8

Dear Reinhold,
I just sent you credentials and the file for this plugin! To verify your steps:
1) Install plugin
2) Enable plugin
3) Inside plugin use credentials i sent you
4) Make an order as a client
5) When you try to make another order at checkout page of One page checkout you will see your data saved from previous order. I mean the data at left column (billing data). I suppose that you will use a debuging line at your plugin to be able to see the zip code you enter
6) If at second column you select that shipping data is different from billing data and you enter zip code there, then you will see at your debug that zip code is correct and if you try to change again you will see that zip code again changes!
7) Now if you leave it like it is (box at second column that says shipping address is same as billing address) you see the zip code you entered at your last order. Now, at this column (billing data column) you try and enter a different zip code. After ajax refresh (just click on another field) you will see at the debug that system keeps previous zip code. In order to be assured that zip code works with this plugin, you can create default VM Shipping methods and you will see that changin zip code at billing data column will update correctly the default VM shipping rules but the debug from your plugin will keep the same zip.

Please Log in or Create an account to join the conversation.

Zip not working at all 09 Dec 2016 23:35 #9

Dear PM4698,
Thanks for these instructions and the OPC plugin! Following your steps, I have now been able to reproduce the issue. It indeed seems to be some caching issue inside our plugin, as the plugin gets the correct ZIP code (which can be seen when you add Name="ZIP: {ZIP}" to your rules). It just does not re-evaluate the rules but re-use the results of some previous calculation...

We'll keep you updated about our progress fixing this issue.

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

Zip not working at all 15 Dec 2016 17:48 #10

Hello there! Any progress on the issue?

Thank you in advance

Please Log in or Create an account to join the conversation.

Zip not working at all 22 Dec 2016 22:15 #11

Dear PM4698,
I have now tried to delve deeper into the issue, but realized that I in fact still cannot reproduce the issue on a local test environment (I had a typo in my test rules, so it appeared to me that the wrong / outdated rule would be applied...

Do you have a test / devel installation available where I can see the problem in action?

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

Zip not working at all 23 Dec 2016 04:25 #12

Sure i am sending you in 2 minutes credentials and links to your email to see

Please Log in or Create an account to join the conversation.

Zip not working at all 24 Dec 2016 17:52 #13

Dear PM4698,
Thanks for the link to your development shop. Indeed, on your installation, changes to the ZIP code (or most other billing address fields) do not cause a reload of the shipping costs. However, from what I see, this is not due to our plugin, but a general issue with the OPC plugin (the cart does not even phone back to the server to check whether the change of the ZIP code causes a new shipping amount).

The VP OPC plugin has a (advanced) setting that allows the user to configure which address fields cause an update of the shipment / payment costs when they are change. If you selected any address field there, changes to any other field will not cause a recalculation of the shipping costs.
Can you please check your VP OPC settings (the advanced tag) whether you have explicitly selected any address field in the "Custom BT Address Update Fields" settings. That would perfectly explain the issue you have with the OPC not recalculating shipping costs.

Best regards and happy holidays!
Reinhold

Please Log in or Create an account to join the conversation.

Zip not working at all 25 Dec 2016 06:27 #14

Hello there!

I have zero selections at those fields!And also one page checkout filters normally default shipping methods

Please Log in or Create an account to join the conversation.

Zip not working at all 19 Feb 2017 14:19 #15

Dear PM4698,
Have you found a solution to your problem or at least the cause of your issues?

Best regards,
Reinhold

Please Log in or Create an account to join the conversation.

  • Page:
  • 1

VM - Shopping cart

 x 

Cart empty

Login Formular